7.8

pretty bad
Typical Repair Cost:
$347.00
Average Mileage:
98,468 miles
Total Complaints:
10 complaints

Most common solutions:

  1. not sure (8 reports)
  2. drive belt and belt tensioner replaced (1 reports)
  3. replace mass airflow sensor (1 reports)
  4. replaced catalytic converter (1 reports)
Get notified about new defects, investigations, recalls & lawsuits for the 2001 Chevrolet Impala:

Unsubscribe any time. We don't sell/share your email.

problem #10

Jan 102013

Impala 3.4L V6

  • Automatic transmission
  • 123,000 miles

had some lag on acceleration, and a screeching sound. replaced the drive belt and tensioner and waalaa

- , Houston, TX, USA

problem #9

Jul 222011

Impala 3.8L

  • Automatic transmission
  • 67,000 miles

I started having problems with the acceleration with my 2001 Chevy Impala. After fixing another issue with the traction control, I found that there was still an acceleration problem. The car is shifting poorly and has no power. The garage recommended a tune up so I did one and the problem still exists. I had the transmission rebuilt 18 months ago and even though there is shifting problems, I believe it is engine related because it is sucking down gas like crazy.

- , Lima, New York, USA

problem #8

Dec 142007

Impala

  • Automatic transmission
  • 118,000 miles

My car is not the best at accelerating and going over big hills is not fun. You really have to coax it into going faster. If you hit the gas a little to hard it kind of jolts you forward a bit. The car's tempermental for sure.

- , Fargo, ND, USA

problem #7

Jun 022008

Impala LS 3.8L

  • Automatic transmission
  • 80,675 miles

My daughter Chevy Impala LS 3800 has been running flawless up until it started to hesitate during acceleration and the rpm would go to 3000 before the car would move.Had the catalytic converter replaced and it worked fine.

- , Lumberton, NJ, USA

problem #6

May 192008

Impala LS 3.8L V6

  • Automatic transmission
  • 138,000 miles

My car is very what I call sluggish. It will not pick up speed. When I try to give it a little gas the car just seems to sput and spout until the rpm gets to about 3000 and then it will go to about 50 mph and then I cannot get it to go too much over that. Sometimes when the car will jerk a little when it is trying to accelerate but can't. Can anybody tell me if they have had this problem and has found the solution. Much appreciated.

- , Muskegon, MI, USA

problem #5

Apr 242008

Impala LS 3.8L

  • Automatic transmission
  • 65,000 miles

Engine hesitates when accelerating around 2000 RPM's. If I hold the gas pedal around the 2000 RPM area it continuously will hesitate until either I get of the gas, especially toward hill or approach the highway from ramp

- , Rochester, NY, USA

problem #4

May 082007

(reported on)

Impala 3.4L V6

  • Automatic transmission
  • 92,000 miles

We are having the same problem as #2 complaint (from stonesc/ goose creek sc)on Chevy Impala 2001.

No power, very slow acceleration... once I get up to @ 30-33mph, shifts into some gear, takes off for 2 seconds and goes back into a slow acceleration to get up to 45mph. Getting up a hill takes a long time and I do not want to give it any more gas than necessary for fear of it blowing something up or out!

We have changed the trans. filter and fluid, checked the erg valve, (which was the OBD code autozone's computer read)and it seems to be working properly, cleaned the erg valve's airway, checked the hoses for leaks... it still will not accelerate properly. What's next?

Sincere appreciation for any suggestions...

thank you

AG Kennedy

- , Gastonia, NC, USA

problem #3

Aug 122007

(reported on)

Impala 3.4L V6

  • Automatic transmission
  • 160,000 miles

When the car was running at first I had to let the car warm up to even drive it. If I didn't the battery light would blink on and off, when I got on the gas it would just "putt-putt" and go dead

- , Nacogdoches, Texas, USA

problem #2

Sep 212006

(reported on)

Impala LS

  • 81,000 miles

My car accelerates very slow. I am afraid to even try to accelerate faster cause I don't want my car to not work. Whenever I do try to take off faster it does not shift properly. If I accelerate quickly I have to release the gas and then step on it again. It really makes me mad. I had about $2,000 worth of work done less about 4 months ago at the dealership and am really disappointed that my car is acting up. I had taken it in for a tune up and asked them to check everything. It seemed as though they were happy to take my money but only put in half the effort. I'm so sick of putting money into this car and still having problems. I bought the car brand new 5 years ago.

- , Goose Creek, SC, USA

problem #1

Apr 092006

(reported on)

Impala

  • 60,000 miles

First noticed irratic idling, rpm's would jump 2000, then almost stall. Then started having hesitations on acceleration, really bad on hard acceleration where I thought something was going to break. Then noticed on cruise control, stuttering. Took long time to log a code, and only did it once. Dealer said Air Flow sensor once I could finally show up with the code present. Phone around for used, lots out there.

- , North Bay, Ontario, Canada